Absinthe 2.0 – Untethered Jailbreak for iPad, iPhone & iPod touch 5.1.1

The Chronic Dev team has released Absinthe 2.0 which will jailbreak most devices on firmware 5.1.1. I’ll provide a list below of compatible devices. First, I’m going to jailbreak my new iPad (3). It’s current firmware is 5.1 so I am upgrading to 5.1.1. Before jailbreaking I recommend backing up your device. I use iCloud to backup but you can also connect to iTunes and under devices, right click the device and choose backup. It had been suggested to wipe/restore your device before running this jailbreak to save time. It may take up to 30 minutes if you don’t. I have so much on my device that it would take longer than that to restore so I’m trying it with all my apps, pictures and settings.

Once backed up you need to download Absinthe to your computer. MacOSX, Windows & Linux are supported.

Download

Once installed, open Absinthe and connect your device via USB. Once the device is connected it will be detected by Absinthe. Just click “Jailbreak” and wait…

Mine took about 20 minutes.

Device Compatibility:

iPad1,1 – 2,1 – 2,2 – 2,3 – 3,1 – 3,2 – 3,3

iPhone2,1 – 3,1 – 3,3 – 4,1

iPod3,1 – 4,1

(Support for iPad2,4 will be added at a later date)

1 Star2 Stars3 Stars4 Stars5 Stars (No Ratings Yet)
Loading...

Comments

  1. Hey Doug, I got an error (could not connect lockdown) but Cydia was still loaded. Have you heard anything like that? Everything looks fine but I just wanted to see if you or anyone else encountered this problem.

  2. Extremely complicated. Please explain step by step. I don’t have any of the things you mention in my Ipod 4th generation

  3. Where is the download link? Is it the button that says Download in blue? Please answer quickly!

  4. I am totally confused on how to get cydia on my iphone 4. Please tell me how to get cydia for free.
    Please please please please please please

  5. harry easton says:

    how do you back up your ipod

  6. i have iphone 4
    version 6.1.3(10b329)
    modem firmware 04.12.05
    which version of jailbreak should i use ….

Speak Your Mind

*